Blog Articles Not Appearing In Auto-Generated Sitemap

Hello all,

I hope everyone is doing well! I have launched several migrated Adobe BC > Treepl CMS sites lately and so far it has been an amazing transition. For one of my clients, however, my SEO team just noticed that the blog articles are not appearing in the auto-generated sitemap.xml file, which is hurting our SEO efforts. I went in to make sure that none of the articles were ‘hidden’ from search engine results and I turned the SEO settings on in the admin. I even clicked the ‘Rebuild Index’ button at the top and checked back, and I still don’t see the blog articles appearing in the sitemap.xml file. I’m hoping this is just something simple that I’m missing on my end - can anyone offer some insight as to what I need to do to get the blog articles added to the sitemap.xml file? I have a support ticket in, but I’m hoping if I can get help here I can mark the ticket as resolved so I don’t have to bother support. Especially if it’s a simple setting that I’m just missing.

Thank you in advance!

  • Ryan

I’m seeing the same in my tests.
I managed to get a post to appear in the sitemap by re-saving it from the SEO tab - but only if making a change to something, a straight save didn’t have any effect (I just added an SEO priority value).

To do in bulk, the “Enable All” in the SEO section also worked - but obviously this effects the whole site so may not be suitable.

Exporting the posts and importing with the Show for Search Engines enabled might also jump-start this but I haven’t tried (might need to make some data change in this also).

Definitely looks like a bug so perhaps add a link back to this discussion in your support ticket.

Maybe try editing the actual blog folder and ensuring this is enabled for search as we saw this be an issue recently for one site.

Thank you for the help here! I will try your suggestions so that I can get the clients sitemap updated for the time being. I did submit a support ticket and I heard back today. They are aware of the bug and working with the team to fix it. Boy, night and day from the support at Adobe BC - these guys are great.

Thank you again!

  • Ryan

Hello Adam,

Quick question for you - I selected ‘Enable All’ and saved on the SEO tab in Treepl CMS and then clicked the ‘Rebuild Index’ at the top, and I still don’t see the blog articles in the sitemap.xml file: Is this the same thing you did that worked for you? The Treepl team is looking into it, but I just thought I’d double check with you to make sure I’m doing the right thing before I decide it’s not working for me.

Thank you again!

Yes @StudioRTP, the Enable All for search button worked for me.
Note: you only need to click this button, you don’t need to click the Save button on the SEO settings page as well. I mention this because the Enable All can take a few moments to finish so maybe clicking Save and/or navigating away from that page before it’s done might interrupt the process???
Also, rebuild the index afterwards just to sure too.

Thank you Adam, I didn’t realize that clicking save would interrupt the enabling, so I appreciate the extra info. I just followed your instructions and I don’t see any of the blog articles appearing on the sitemap.xml file. I waited around 15 minutes and then did a rebuild. Hopefully support will be able to track down the issue. Thank you for your help!!

  • Ryan

Hmm, strange.
Just to clarify, I don’t know if clicking Save does interrupt the process… just a thought :slight_smile: