BUG? Content Module Layouts being renamed with (1) or (2) etc randomly on save

I added a couple new layouts (list view) for a custom module. Named them “HeaderList” and “FooterList” (type: List for each). Files are created, everything shows up and works great by connecting the module by selecting layout: “HeaderList”.

Then, if I make any changes to the layout, the system randomly (not every time, but almost) renames with a “(1)” after it, then a “(2)”. Next thing I know, the custom module just disappears from the page because the component module’s layout no longer matches the name I originally gave it. If I manually go change the layout to: “HeaderList (1)” it will work for a bit. Until the system renames my layout file to “Header List (2)”. If I try to re-name the newly named file back to “Header List”, it acts like changes are successful but the name doesn’t actually change. The only way I can get rid of the (1) is if I create a brand new layout file with an entirely different name (e.g. “Header”). And sure enough if I make any changes to that file later, it will rename itself with “(1)” again. Once, I didn’t even make a change to the file, I came back into the LAYOUTS area and it was already renamed with “(1)”. I’m going to lose my mind. I’ve tried names with/without spaces, with/without “-”, with/without “_”, same problem each time.

I’ve confirmed it is happening if I use only the Treepl Admin. I was very, very careful to name a new file, give it a new name, paste in new code, and carefully click the SAVE button. It also happens if I use only Dreamweaver files/ftp. It also happens if I use a combo of Treepl Admin and DW ftp.

I’ve also noticed a couple times my newly edited layout also just disappeared!? “Footer” and “FooterList” completely disappeared on me in the Admin. Looking at the server via FTP, the file was still there, but the Admin doesn’t see/show it.

Any suggestions? Please help, super concerned and going to miss a deadline.

I tried putting in the Layout code # (e.g. layout: “5293”) instead of the layout name, but the component did not show up. I would LOVE that as a workaround, because the layout # isn’t changing randomly on me. Instead, I have to go into my component code and re-name the layout: “name” over and over again. No solution for the couple that disappeared… only saving grace is I had backups of the code along the way on my local machine.

NOTE: I have NOT had beta “Advanced URL Manager” on during this time. After countless automatic renames, I tried turning it on to see if it may help. Same problem after turning it on. So, I’ve turned it back off.

1 Like

I can reproduce that on my instances. @A3CS wrote about this a couple of days ago on Slack, too. Agreed, that needs to be fixed quickly.

1 Like

Oh I actually came across this too specifically in layouts. But I couldn’t for the life of me figure out how so I left it… Good to know its reproducible.

Its like there is a cached copy somewhere that we cant see so the system adds a 1 to it… But we cant see the first instance so its numbered.


Hello Craig Whitlock. Can you provide a link to the site where this problem occurs?

I can confirm this is happening to me as well… seems to be happening to layouts which contain the word “List” or “Detail” in the title - for instance, a layout called “Footer List”. You can create it…, but when you go back in to save it, it adds a (1). I recall this happening a few months back, was fixed, but now it is back.

I have had the problem several places. Both in layouts and in pages. Should be relatively easy to replicate, let me know if you want a video of it, I will try and see if I can replicate :slight_smile:

This is driving me nuts! Anyone find a solution to this yet?

Did you try the suggestion of not including the word “List” or “Detail” in the layout name? For example, do you still have the problem if you call your list “Thumbnails” instead of “Thumbnails List”?

In my experience/testing, name doesn’t affect it at all. I usually can anticipate when it happens, as it sends me back to the Dashboard upon save instead of staying on the saved Layout.

Hi guys! We’re planning to release a hotfix of this issue this Wednesday.


Hi guys! The issue has been fixed.

Thank you! Everything appears to be working as expected now. Appreciate it

…with one exception. I still see this happening with Content Templates - system is adding (1) and duplicating the template. Although this is a bit different/better than the original problem with Layouts, because I’m able to delete and/or re-save the original template via Admin or FTP.

Hi @craigwhitlock Please submit a support ticket on this.