Home URL blank for seo

It might be a silly question.

I have the home page URL that I can’t leave blank so the label is:


What’s the best way to have this as URL for SEO

Do I set up a redirect?
Or have it in the canonical?

Hi @luke
Since you will set your home page with the “Set as home page” option, the system will resolve that page at website.com.au/ and it will be added to your XML sitemap that way also.
So as long as you don’t actively use website.com.au/home in any links (just use / to link to your home page), then that URL should not be indexed by search engines.

Thanks mate I did see that but just wasn’t sure why you can’t just put it as / in the url or even leave it blank

Also, I have this problem. Treepl Support suggested I disable www. address but I’m not sure if that is correct.

Why is the www. address as a separate domain

www is actually just a subdomain. Just like having https://shop.yourdomain.com for example.
I think it’s a remnant of the earlier internet as a way to identify internet traffic/content, but it’s perhaps a little redundant these days (or maybe not…).
You can open that can of worms for yourself here: :slight_smile:

Personally, I configure for both www and non-www (with auto redirect to the www) as standard, because that’s what people and systems are expecting and are used to.

1 Like

That’s what I thought I was doing but some of these tools are giving me these warnings. Also the https and http how would I even fix that as the http no longer exists

The http → https should already be taken care of by the server.
The www redirect you can resolve by setting a domain redirect - see docs here: Domains

Hopefully, that clears the error for both cases.

1 Like

Ok thanks again mate

Once I set up the domain redirect www to non-www it cleared all errors.

1 Like

Luke, what tool did you use to produce that report?

It’s Woorank