Recaptcha3 Errors

Sometimes forms with Recapcha3 display a ‘Recaptcha Error’ even though the form is completed by a real person. This seems to be quite random as I can test the form on multiple browsers and it works fine and then suddenly it throws an error.

I have had a couple of website owners mention that their customers have had this issue where they couldn’t submit a form but then when I test them they are working fine.

Does anyone know the reasons why Recapcha3 doesn’t validate? Is it that the page hasn’t been on screen long enough (or for too long) or browsers/versions that aren’t compatible? @Violetta.S do any of these issues cause the validation to error?

@SiroccoDigital do you have the new or old recaptcha script in place?
The old one did have timeout issues. The new one initiates at time of form submission an dI haven’t noticed any issues with it yet.

If you generate a dummy form with v3 you can compare the two script and update if needed.

@Adam.Wilson it is the new Recaptcha 3 that I have used and the site has only been online for about a month. I struggling to provide a reason to the client that could explain it.

Had the same with a client of ours. They kept getting emails from customers saying that it wasn’t working. I checked it over and over again, worked every time. Suddenly I experienced it as well. I couldn’t see any pattern to it, so I just reverted it to V2 since I wanted to be sure it worked because the client was tired of it not working.

@SiroccoDigital Please submit a support ticket on this, our developers will look into this.

Hi Peter

@Peter-Schmidt Just wondering if you ever got a resolution to this recaptcha3 issue you were having. Are you still using V2 or did you revert back V3. Form completions for some of our clients can be worth thousands so it is important they always work for us, and why I was curious.

We have been able to troubleshoot one instance down to a customer using Explorer 11. It says in the reCAPTCHA documentation that it doesn’t play nicely with Explorer 11 or under. Would be interested to see if this also accounts for your issues @JFK


@JFK - The site where I initially had problems I haven’t change it from V2, so not entirely sure how it works. Have just implemented V3 on a new site and so far I haven’t been able to get it to fail.

The Explorer error that @SiroccoDigital mentions sounds very plausible, we always run into problems with Exploder :boom: :slight_smile:

Just a thought, have not tried it, but if it is Exploder that is causing the problem you might be able to implement both V2 and V3, and have an IF statement checking the browser and if it is below Exploder 11, it uses V2 and otherwise V3 :thinking: